Changes between Version 4 and Version 5 of AncestrisDevPlugins


Ignore:
Timestamp:
Apr 18, 2012, 9:09:47 PM (9 years ago)
Author:
Francois
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • AncestrisDevPlugins

    v4 v5  
    55== Installation de Netbeans ==
    66
    7 La première chose à faire est d'installer Netbeans et de reprendre le source d'Ancestris. Toutes les explications sont données, à la fois sur ce site et sur le [http://www.arvernes.com/wiki/index.php/Genj_-_Développement wiki d'Ancestris]. Il faut vous y reporter.
     7La première chose à faire est d'installer Netbeans et de reprendre le source d'Ancestris. Toutes les explications sont données, à la fois sur ce site et sur le [http://www.arvernes.com/wiki/index.php/Ancestris_-_Développement wiki d'Ancestris]. Il faut vous y reporter.
    88
    99== Comment faire un plugin ==
     
    1212
    1313== Numérotation des versions ==
    14 Chaque module (ou plugin) pour l'application Ancestris doit avoir un numéro de version afin de pouvoir être correctement mis à jour par le mécanisme de mise à jour des plugins. Ce schéma de numérotation des modules Ancestris suit la convention standard des modules !NetBeans décrite dans [http://openide.netbeans.org/versioning-policy.html#3 ce doccument] avec quelques précisions suivantes:
     14Chaque module (ou plugin) pour l'application Ancestris doit avoir un numéro de version afin de pouvoir être correctement mis à jour par le mécanisme de mise à jour des plugins. Ce schéma de numérotation des modules Ancestris suit la convention standard des modules !NetBeans décrite dans [http://openide.netbeans.org/versioning-policy.html#3 ce document] avec quelques précisions suivantes:
    1515 * La version finale (Major version) n'est pas utilisée pour le moment et sera considérée comme étant -1 par !NetBeans
    1616 * La version d'implémentation n'est pas utilisée pour le moment